Jump to content
Magento é no Mestre Magento
Daniel

Matrix Rate não funciona com máscara de CEP.

Mensagens Recomendadas

Olá pessoal, sou novo aqui e não achei este tópico, se tiver algum me informe por favor que coloco no local correto.

Estou usando Magento versão 2.2.5. 

Instalei o módulo Matrix Rate perfeitamente e tudo estava funcionando normal até eu instalar um módulo para deixar o cadastro de clientes com as configurações para o Brasil, incluindo máscara para o CEP (xxxxx-xxx).
Após esta instalação, se adiciono uma faixa de CEP no Matrix Rate, esta faixa não funciona. Funciona apenas se deixar todos os CEPS (*) e filtrar por estado ou cidade. Mas no meu caso preciso mesmo que seja por CEP.
Alguém passou por algo parecido e conseguiria me ajudar?

Obrigado.

Share this post


Link to post
Share on other sites

Olá @Daniel

O problema é que o Matrixrate não consegue comparar 01001-000 com 01001000, e esse modulo deve estar passando no value do campo esse traço. Qual é esse modulo que esta usando? Compartilha conosco para que possamos ver o que o modulo esta passando exatamente para o Matrixrates.

Share this post


Link to post
Share on other sites

Claro, acabei me esquecendo de detalhar.

O módulo que estou usando é o Brazil Customer Attributes, segue link:

https://github.com/eduardoddias/Magento-SystemCode_BrazilCustomerAttributes

 

Foi o único que encontrei para a versão 2.2.5 do Magento. Se existir algum outro que funcione com o Matrix Rate e puderem indicar, eu agradeço. Ou se puderem ajudar com este, também resolve. ?


Muito obrigado.

Share this post


Link to post
Share on other sites
On 8/10/2018 at 9:37 AM, Daniel said:

Claro, acabei me esquecendo de detalhar.

O módulo que estou usando é o Brazil Customer Attributes, segue link:

https://github.com/eduardoddias/Magento-SystemCode_BrazilCustomerAttributes

 

Foi o único que encontrei para a versão 2.2.5 do Magento. Se existir algum outro que funcione com o Matrix Rate e puderem indicar, eu agradeço. Ou se puderem ajudar com este, também resolve. ?


Muito obrigado.

Alguém já usou Matrix Rate no Magento 2.2 com máscara no CEP? Sabe como posso corrigir ou tem dica de algum outro módulo?

Obrigado.

Share this post


Link to post
Share on other sites

Olá Ariel.

Estou usando magento 2.3.1 com idioma em português e diferente do Daniel não estou usando o módulo Brazil Customer Attributes, porém instalei o módulo Imagination Media Correios.

E também instalei o matrixrate, porém, tenho o mesmo problema: não retorna o frete cadastrado na tabela.

Eu desabilitei o modulo Imagination Media Correios (que fuinciona corretamente) para testar, porém, só com o matrixrate não retorna o valor do frete.

Eu segui sua dica no video https://www.youtube.com/watch?v=rVjrQ_z1Dwg mas não funcionou aqui. Imagino que deva ser o tratamento do "traço" que é inserido ao digitar o cep.

Saberia me dizer qual arquivo do modulo matrixrate (ou outro arquivo) devo alterar para que funcione no meu caso?

Desde já, muito obrigado pela atenção.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Convidado
Responder esse tópico...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Informação Importante

Ao usar este site, você concorda com nossos Termos de Uso (leia).