Jump to content
rafael manfrin

Erro ao instalar modulo One Step Checkout Magento 2 (OSC) - Clean Checkout

Mensagens Recomendadas

Boa tarde tudo bem? estou tentando instalar o modulo, porem esta dando o seguinte erro: __construct(/mageworx/extensions/zip): failed to open dir : No such file or directory. Eu tenho que criar uma pasta com esses nomes? onde ficaria? Obrigado

Share this post


Link to post
Share on other sites

Então descobri, era um tag que havia coloca no composer, mas agora estou com outro problema, quando clico no dentro no admin no modulo, ele fica um tela em branco e da esse erro

 

[2018-10-09 02:48:47] main.CRITICAL: Notice: Undefined index: label in /var/www/html/vendor/magento/framework/Data/Form/Element/Select.php on line 68 [] []

 

estou usando o magento 2.2.4 tem algum problema? Obrigado

Share this post


Link to post
Share on other sites

Oi @rafael manfrin

Pelo que percebi trata-se de um erro nativo, algum select do modulo não possui um label definido.

Veja que existe um relato desse mesmo problema nesse link https://github.com/danslo/CleanCheckout/issues/62

Ultimamente o pessoal tem tido bastante problema com o Clean Checkout, eu vou fazer uns testes em minha maquina e caso eu consiga te aviso.

Share this post


Link to post
Share on other sites

Oi @rafael manfrin

Fiz alguns testes aqui e o grande problema é a falta de informação por parte do pessoal que desenvolveu o modulo referente a qual versão de PHP e Magento que o modulo funciona corretamente. O correto é informar qual versão de Magento o modulo esta preparado para funcionar.

Na versão 2.2.* tive diversos problemas para instalar, ele reclama de versão do framework do Magento então entendo que o modulo não esta habito para funcionar na versão 2.2 ainda, e muito provável a versão de php tem que ser a 7.1 ou superior, mas não ha informações sobre isso, o que é muito ruim.

Instalei o modulo mais recente deles no Magento 2.1.14 com PHP 7.0.26 e funcionou perfeitamente. Infelizmente o modulo esta mais estável para a versão 2.1.* do Magento, ok?

Espero ter ajudado!

Share this post


Link to post
Share on other sites

Ah blz muito obrigado, infelizmente minha loja eu estou seguindo todas as atualizações do magento, então a loja ja esta no 2.2.6 vou desinstalar o modulo. Teria algum modulo legal de checkout para indicar? vejo que o que vem padrao no magneto e bem ruim. Obrigado

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Entrar

Already have an account? Sign in here.

Sign In Now

×

Informação Importante

Ao usar este site, você concorda com nossos Termos de Uso (leia).